システム開発ブログ

システムソリューション事業部

MySQL

MySQLのエラー [ERROR 1548]

先日、MySQLのバージョンを5.5にアップしたところ、

「Cannot load from mysql.proc. The table is probably corrupted」

なるエラーが発生するようになりました。

Navicatでテーブルの変更などを行おうとすると上記エラーが発生し、
変更が行えなくなってしまいました。

調べたところ、古いバージョンのテーブル構造で作成されているため、
上記エラーが発生しているようです。
古いバージョンと5.5とではテーブル構造が異なるため、
古いバージョンで作成したテーブルが残っているとエラーが発生します。

例えば、MySQLのバージョンは5.5でも
ダンプファイルなどから復元した元のバージョンが古いと
エラーが発生すると思います。

上記エラーを解決するには、以下のコマンドを実行してください。

mysql_upgrade -u root -p

コマンド実行後に再度確認したところ、エラーは解消されました!

システム周りのお悩みを解決します

まずは無料ダウンロード

この記事に関連する記事の一覧


システム開発ブログ

Twitterでilovex_officialをフォローしてください

カテゴリー

以前の部署別ブログ

ページのトップ